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Chapter 1

About this API

About this API

Summary

ADP Workforce Now enables users to create a Pay Data batch for a payroll cycle to include the following:

Earnings
Deductions
Reimbursements
Reportable Earnings and Benefits
Temporary Cost Number
Temporary Department Number
Allocations

The Payroll Data Input Application Programming Interface (API) enables you to build a data connector application for clients to transmit data that
is sourced in your application to a specific Pay Data batch in ADP Workforce Now.

What's New in this Guide?

September 2022

Added support for 3 new pay data fields
Cancel Automatic Payment
Shift
Tax Frequency

August 2022

Added clarity regarding passing pay rates and highlighting the depreciation of 'codedHoursEarningInputs' 
Info: All hours and earnings are supported by the 'earningInputs' object and should be the only object used to submit hours or earnings.
In order to not break existing integrations that use 'codedHoursEarningInputs' the fields will be accepted but may not have the same
behavior as 'earningInputs'. 
info: If sending the rate for one earning in the array, a rate should be sent for all codes in that array. If only 1 rate is sent that rate
would be used for all records on that row. 

April 2021

Added a note point for the section Regular and Overtime Earning Inputs Data Dictionary under Chapter 1- About this API

March 2022

Updated Menu Access requirements to include new Payroll Dashboard.
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December 2020

Added "ADP Workforce Now API Release Plan" in Chapter 5 - Known Issues and Limitations
Added below information in Chapter 6-Appendix B: Pay Data Fields Not Handled by the Payroll Data Input API
ADP client practitioner could use file based import as a work around. 

October 2020

Added link in Chapter 1 for Video recording of an overview of this API  

August 2020

Removed Grid Template Setup in ADP Workforce Now information in this chapter.
Added the API[/events/payroll/v1/pay-data-input.modify/meta?companyCode=94N&fileNumber=078765] with response under
the API Usage section in Chapter 2 - Use Case: Adding Entries in a Batch.

May 2020

Revised the following in this chapter:
Added a schema location for Rate Code in Regular and Overtime Earning Inputs Data Dictionary.
Added codeList APIs for Temporary Cost Number and Temporary Department Number in Temporary Cost Number, Temporary
Department Number, and Allocation Data Dictionary section.
Updated the APPEND functionality in the Pay Data Input API Postman Collection.

Revised the following in Chapter 2 - Use Case: Adding Entries in a Pay Data Patch:
Added negative test cases on rate code along with GitHub links in the Responses section.
Updated the responses for meta API in the API Usage section.

Added Chapter 3 - Use Case: Appending Entries to an Existing Pay Data Batch 
Revised the following in Chapter 5 - Known Issues and Limitations:

Added Issue: Meta Call is not giving any codeList details for ratecodes.
Added Issue: Event notification is not supported.
Added US1719297: Update Pay Data Input API to reflect the true batch name

Moved the following to the Appendixes from Chapter 1 - About this API:
Appendix A: Pay Data Types Handled by the Payroll Data Input API
Appendix B: Pay Data Fields Not Handled by the Payroll Data Input API

Recent Webinar Overview

You can view an overview of this API provided on October 2nd, 2020 using this link Passcode: PhD6zumk
Payload collection used in the video overview is available at here

Process Overview

The following table illustrates how clients use your data connector application, which is built using the Payroll Data Input API.

https://developers.adp.com/articles/faq/what-is-the-release-plan-for-adp-workforce-now-apis
https://developers.adp.com/articles/preview/guide-payroll-data-input-api--guide-for-adp-workforce-now-0?chapter=5
https://developers.adp.com/articles/preview/guide-payroll-data-input-api--guide-for-adp-workforce-now-0?chapter=6
https://developers.adp.com/articles/guides/payroll-data-input-api--guide-for-adp-workforce-now?chapter=2
https://developers.adp.com/articles/preview/guide-payroll-data-input-api--guide-for-adp-workforce-now-0?chapter=2
https://developers.adp.com/articles/preview/guide-payroll-data-input-api--guide-for-adp-workforce-now-0?chapter=3
https://developers.adp.com/articles/preview/guide-payroll-data-input-api--guide-for-adp-workforce-now-0?chapter=5
https://developers.adp.com/articles/preview/guide-payroll-data-input-api--guide-for-adp-workforce-now-0?chapter=6
https://adpmeet.webex.com/recordingservice/sites/adpmeet/recording/playback/1e1c2777fcbb48fd99b0f786ba35b243
https://www.getpostman.com/collections/929ca7542c0378353210
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Required Setup Steps

Setup Pages in ADP Workforce Now

The Payroll Data Input API supports all earning and deduction codes, including the earning and deduction codes added by clients. Clients need
to make sure the codes and numbers used by your data connector application are added and configured in ADP Workforce Now by
selecting Setup > Tools > Validation Tables > Payroll > Paydata.

The following table lists the records in your data connector application and how they correspond to the fields on the Paydata page in ADP
Workforce Now.

 

Before You Begin Using the Payroll Data Input API

The following sections document the requirements for using the Payroll Data Input API.

  Actor Task Description

1 Payroll Practitioner
Selects the company code, employees, and file numbers to be
imported.

2 Payroll Practitioner Enters a batch number and initiating the Pay Data import.

3 Your application
Automatically creates a new batch and imports Pay Data in ADP
Workforce Now.

4 Payroll Practitioner
Reviews the import result on the ADP Workforce
Now Paydata page.

5 Payroll Practitioner

Takes actions to balance and adjust, as needed. 
Note: To keep your data in sync with what's on
the Paydata page in ADP Workforce Now, data must be
adjusted in your data connector application.

Records in Your
Data Connector
Application

Fields on the Paydata Page in ADP Workforce Now

Hours and Earnings
Codes

Hours and Earning Codes

Deduction Code Deductions

Temporary Cost
Number

Cost Number

Temporary
Department Number

Department
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Client Requirements

The client must meet the following requirements:

Must be the United States, Canada (AutoPay), or cross border clients.
Due to a limitation, the client must have a Memo Code of 5 and Hours & Earnings Code of T created for each of their active companies.
Within the ADP Workforce Now UI, select Setup > Tools > Validation Tables > Paydata > Hours & Earnings Codes and Setup > Tools >
Validation Tables > Paydata > Memo. If the parameter autoGenerateMemoCode=false is used, Memo Code 5 and Earning Code T are
not required.

API User Requirements

The API user making the request must be assigned to a profile having the following permissions:

ADP Workforce Now menu access to either: Process > Payroll > Pay Data OR Process > Payroll > Payroll Dashboard
Payroll and People Access: View and edit access to target company codes

Payroll Cycle Requirements

To process the API request, the payroll cycle status must be either Entering Payroll Information or Correcting Input, otherwise the request
will cause an error.

Employee Requirements

Before including any employee in the API request, make sure the employee is in an ADP Workforce Now paid position.

Data Dictionary

Batch and Employee Information Data Dictionary

Using the resources listed in the following table, data sent through the Payroll Data Input API eliminates the need for the user to enter batch
and employee information data manually in ADP Workforce Now.

Schema Location Field Name Business Rules Notes

/eventContext/payrol
lGroupCode/codeValu
e

Company Code Always Required

A client could have multiple company
codes. To create a Pay Data batch, the
client needs to select the company code
first.

/eventContext/payrol
lProcessingJobID

Batch ID  

The client needs to assign the batch an
ID. The ID doesn't need to be unique, as
the system would append system
generated characters if the ID is used by
an existing batch.
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Regular and Overtime Earning Inputs Data Dictionary

Using the resources listed in the following table, regular and overtime earning input data sent through the Payroll Data Input API eliminates the
need to enter this data manually in ADP Workforce Now.

Code R is reserved for Regular Earnings and O is reserved for Overtime Earnings.

 

/payDataInput/payee
PayInputs/
associateOID

Not Displayed  
To retrieve the value for an employee,
use GET workers.

/payDataInput/payee
PayInputs/
payrollProfilePayInput
s /payrollFileNumber

File #    

/payDataInput/payee
PayInputs/
payNumber

Pay Number  
The client needs to assign
a payNumber to be used for all entries
included in the batch.

Schema Location Paydata Page Location Notes

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/earningCode/code
Value

NA

The Earning Code.
Use the earning code values which are listed under
"/payDataInput/payeePayInputs/payrollProfilePayInputs/p
ayInputs/earningInputs/earningCode"  in the Meta call
response.

/payDataInput/payeePay

Inputs/payrollProfilePayI

nputs/payInputs/earnin

gInputs/rateCode

Rate Code  

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/rate/rateValue

Temp Rate The Temp Rate associated with the Earning Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/rate/currencyCod
e

NA The Currency Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/numberOfHours

Reg Hours for code RO/T Hours for code O The Hours associated with the Earning Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs

Reg Earnings The Amount associated with the Earning Code.
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Processing Rules

Based on the values included in the payload, ADP Workforce Now will process data according to business rules. ADP Workforce Now has the
following out of box earning codes:

R = Regular Earning
O = Overtime Earning

The following table outlines various input combinations and process results.

/payInputs/earningInp
uts/earningsAmount/
amountValue

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/earningsAmount/
currencyCode

NA The Currency Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs/payInputs
/earningInputs
/earnedPayPeriodWee
kNumber

FLSA WorkWeek
Indicates whether the hours entered for employees are for
week 1 or week 2.

 
Comm
on Use

/rate/
rateV
alue

/numb
erOfH
ours

/earni
ngs
Amou
nt/
amoun
tValue

Displayed on Paydata Page When Request is
Processed Successfully:

 

 

 

 

Notes

         
RegHou
rs

O/THou
rs

TempRa
te

RegEar
nings

O/TEar
nings

 

1

Send
in Hour
s for Re
gular
Earning
.

Null Not Null Null Not Null Null Null Null Null  

2

Send
in Hour
s for Ov
ertime
Earning
.

Null Not Null Null Null Not Null Null Null Null  

3 Send
in Temp
Rate an
d Hours
 for Reg

Not Null Not Null Null Not Null Null Not Null Null Null Used
for Hou
rly
Employ
ee only
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ular
Earning
.

(Pay
Profile
>
Regular
Pay
Rate =
Hourly). 
The Tem
p
Rate wil
l be
used to
replace
the Reg
ular
Rate on
the
employ
ee
record.

4

Send
in Temp
Rate an
d Hours
 for Ove
rtime
Earning
.

Not Null Not Null Null Null Not Null Not Null Null Null

Used
for Hou
rly
Employ
ee only
(Pay
Profile
>
Regular
Pay
Rate =
Hourly).
The Tem
p
Rate wil
l be
used to
replace
the Ove
rtime
Rate. 
You
cannot
submit
a Temp
Rate fo
r Regul
ar
Hours a
nd
another 
Temp
Rate fo
r
the Ove
rtime h
ours for
the
same
file
number
in the
same
batch.

5 Send
in Amou
nt for R
egular
Earning
.

Null Null Not Null Null Null Null Not Null Null Used
for Sala
ried/Da
ily
Employ
ee only 
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Coded Hours and Earnings Data Dictionary

Deprecating codedHoursEarningInputs

All hours and earnings are supported by the 'earningInputs' object and should be the only object used to submit hours or earnings. In order to
not break existing integrations that use 'codedHoursEarningInputs' the fields will be accepted but may not have the same behavior as
'earningInputs'. 

 

Using the resources listed in the following table, coded hours and earnings data sent through the Payroll Data Input API eliminates the need to
enter this data manually in ADP Workforce Now.

(Pay
Profile
>
Regular
Pay
Rate =
Salary
or
Daily).

6

Send
in Amou
nt for O
vertim
e
Earning
.

Null Null Not Null Null Null Null Null Not Null

Used
for Sala
ried/Da
ily
Employ
ee only
(Pay
Profile
>
Regular
Pay
Rate =
Salary
or
Daily).

7

Send in
both Ho
urs and 
Amount
s for Re
gular
Earning
.

Null Not Null Not Null Not Null Null Null Null Null

The Am
ountVal
ue will
be
disregar
ded.

8

Send in
both Ho
urs and 
Amount
s for Ov
ertime
Earning
.

Null Not Null Not Null Null Not Null Null Null Null

The Am
ountVal
ue will
be
disregar
ded.

Schema Location Field Name Notes

/payDataInput/payee
PayInputs
/payrollProfilePayInpu

Various, depends on the Earning The Earning Code Value.
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Processing Rules

Based on values included in the payload, ADP Workforce Now will process data according to business rules. The following table outlines
various input combinations and processing results.

ts/payInputs/earningI
nputs/earningCode/co
deValue

/payDataInput/payee
PayInputs
/payrollProfilePayInpu
ts/payInputs/earningI
nputs/earningsAmoun
t/amountValue

Amount The Earning Amount Value.

/payDataInput/payee
PayInputs
/payrollProfilePayInpu
ts/payInputs/earningI
nputs/earningsAmoun
t/currencyCode

Not Displayed The Currency Code.

/payDataInput/payee
PayInputs
/payrollProfilePayInpu
ts/payInputs/earningI
nputs/rate/rateValue

Rate

The Rate associated with the earning.
Rate Amount
If sending the rate for one earning in the array, a rate should be
sent for all codes in that array. If only 1 rate is sent that rate
would be used for all records on that row. 

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/rate/currencyCod
e

Not Displayed The Currency Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/earningInp
uts/numberOfHours

Hours The Hours associated with the earning.

  Common Use
/rate/rateVal
ue

/numberOfHo
urs

/earningsAm
ount/amount
Value

Displayed on
Paydata
PageWhen
Request
isProcessed
Successfully

Notes

1

Send
in Hours for
client
configured Hour
s and Earnings 
Field type: Other
Hours

Null Not Null Null

Data sent
from /numberOf
Hours is
displayed
under Other
Hours - (code).

If data is sent
from rateValue a
nd amountValue,
they are
disregarded.

2 Send
in Amount for
client

Null Null Not Null Data sent
from /amountVal
ue is displayed

If data is sent
from rateValue a
nd numberOfHou
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Deductions Data Dictionary

Using the resources listed in the following table, deductions data sent through the Payroll Data Input API eliminates the need to enter this data
manually in ADP Workforce Now.

configured Hour
s and Earnings 
Field type: Other
Hours

under Other
Earnings -
(code).

rs, they are
disregarded.

3

Send
in Hours, Rate,
and Amount for
client
configured Hour
s and Earnings 
Field
type: Hours/Ear
nings 
Field value: 3

Null Not Null Null

Data sent
from /numberOf
Hours is
displayed
under Other
Hours - (code).

If data is sent
from rateValue a
nd amountValue,
they are
disregarded.

4

Send
in Hours, Rate,
and Amount for
client
configured Hour
s and Earnings 
Field
type: Hours/Ear
nings 
Field value: 4

Null Null Not Null

Data sent
from /amountVal
ue is displayed
under Other
Earning - (code).

If data is sent
from rateValue a
nd numberOfHou
rs, they are
disregarded.

Schema Location Field Name Notes

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/deductionCode
/codeValue

Various, depends on the Deduction The Deduction Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/deductionRate/
rateValue

Rate The Rate associated with the deduction code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/deductionRate/
currencyCode

Not Displayed The Deduction Currency Code.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/deductionRate/
baseUnitCode
/codeValue

Use the value from meta  



14

Processing Rules

The value in Rate must be part of the payload to post a deduction adjustment or deduction entry.

Memo Data Dictionary

Using the resources listed in the following table, memo data sent through the Payroll Data Input API eliminates the need to enter this data
manually in ADP Workforce Now.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/configurationTa
gs/tagCode

Use the value from meta  

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/configurationTa
gs/tagType
/dataTypeCode

Use the value from meta  

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/deductionI
nputs/configurationTa
gs/tagValue

Use the value from meta  

Schema Location Field Name Notes

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/memoInpu
ts

Various, depends on the Memo. The memo-related entries.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/memoCod
e

Memo  

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/memoCod
e/codeValue

Code  Use the value from the meta.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/memoInpu
ts/memoAmount

NA  
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Temporary Cost Number, Temporary Department Number, and Allocation
Data Dictionary

Using the resources listed in the following table, your data connector application can post Temporary Cost Number, Temporary Department
Number, and Allocation position details through the Payroll Data Input API. This eliminates the need to enter this data manually in ADP
Workforce Now using the Paydata page.

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs/payInputs
/memoInputs/memoA
mount/amountValue

Amount  

/payDataInput/payee
PayInputs/payrollProfi
lePayInputs
/payInputs/memoInpu
ts/memoAmount/curr
encyCode

NA  

POST Schema Location Field Name Notes

Temporary Cost
Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on

Not Displayed  

Temporary Cost
Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationID

Not Displayed
allocationID:2 – Indicates the Cost
Number

Temporary Cost
Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode

Not Displayed  

Temporary Cost
Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode/codeValue

Temporary Cost Number
Use codeList API to get values
API: /codelists/hr/v3/worker-
management/cost-numbers/WFN/1

Temporary Cost
Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode/shortName

Not Displayed  

Temporary
Department Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on

Not Displayed  

Temporary
Department Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationID

Not Displayed
allocationID:3 – Indicates the
Department Number.

Temporary
Department Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode

Not Displayed  

Temporary
Department Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode/codeValue

Temporary Department
Use codelist API to get values
API: /codelists/hr/v3/worker-
management/departments/WFN/1
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Working with Temporary Cost Number, Temporary Department Number, and Allocations in ADP
Workforce Now

Using the components listed in the table above, sending Temporary Cost Number, Temporary Department Number, and Allocations using the
Payroll Data Input API achieves the same result as if the user follows the steps in the following sections within ADP Workforce Now.

Setting the Temporary Cost Number in ADP Workforce Now

1. On the Paydata page, select Insert > Column.

2. On the Insert Column window, select the Paydata list. Select the Temporary Cost Number position.

3. Click Done.

4. Add a column. Under the new column, enter a value for an employee.

The allocationID:2 value in the payload indicates the Temporary Cost Number. To create the batch with Temporary Cost Number, ADP
Workforce Now should have the Labor Distribution and Allocations set to Cost Number using the following steps:

1. Select Setup > Payroll > Company Options. Select the company code and click Labor Distribution.

2. Set the Labor Distribution to Cost Number.

3. Select Setup > Payroll > Company Options. Select the company code and click Allocations.

4. Set Allocations to Cost Number.

Setting the Temporary Department Number in ADP Workforce Now

1. On the Paydata page, select Insert > Column.

2. On the Insert Column window, select the Paydata list. Select the Temporary Department Number position.

Temporary
Department Number

/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode/shortName

Not Displayed  

Allocation (ALA)
/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on

Not Displayed  

Allocation (ALA)
/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationID

Not Displayed
allocationID:1 – Indicates the
Allocations

Allocation (ALA)
/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode

Not Displayed  

Allocation (ALA)
/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode/codeValue

ALA Position  

Allocation (ALA)
/payDataInput/payeePayInputs/payroll
ProfilePayInputs/payInputs/payAllocati
on/allocationTypeCode/shortName

Not Displayed  
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3. Click Done.

4. Add a column. Under the new column, enter a value for an employee.

The allocationID:3 value in the payload indicates the Temporary Department Number. To create the batch with Temporary Department
Number, ADP Workforce Now should have the Labor Distribution and Allocations set to Department Number using the following steps:

1. Select Setup > Payroll > Company Options. Select the company code and click Labor Distribution.

2. Select Setup > Payroll > Company Options. Select the company code.

3. Click Allocations.

Setting the Allocations in ADP Workforce Now

1. On the Paydata page, select Insert > Column.

2. On the Insert Column window, select the Paydata list. Select Allocations Position Number.

3. Click Done.

4. Add a column. Under the new column, enter a value for an employee.

The allocationID:1 value in the payload indicates Allocation positions for Cost Number and Department Number.

1. Select Setup > Payroll > Company Options.

2. Select either Cost Number or Department as the Allocation method your company uses to allocate employee hours and earnings.

3. Select the Automatic Allocation by Percentage to allow your company to distribute an employee's hours and earnings to multiple
departments or cost numbers on a regular basis, by percentage. This should total 100 percent.

4. Select Manual Posting of Allocation in Paydata to allow your company to distribute an employee's hours and earnings to multiple
departments or cost numbers through postings in paydata.

The following conditions for allocations in the payload exist based on your selections in steps 3 and 4:

When both Automatic Allocation by Percentage and Manual Posting of Allocation are checked, it takes values from 1-99 and "".
When only Automatic Allocation by Percentage is checked, it takes the values as "" and 1.

When only Manual Posting of Allocation is checked, it takes values from 2-99 and "".

When using the Allocation positions, the employee should have allocations set up under People > Employment > Employment Profile >
Corporate Groups > Allocations and either use Temporary Cost Number or Temporary Department Number.

Processing Rules

Based on values included in the payload, ADP Workforce Now processes data according to business rules. The following table outlines the
various input combinations and processing results.

  Common Use
/payAllocation/a
llocationID

/payAllocation/a
llocationTypeCod
e/codeValue

Displayed on the
Paydata Page
When Request is
Processed
Successfully:

Notes
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  Common Use
/payAllocation/a
llocationID

/payAllocation/a
llocationTypeCod
e/codeValue

Displayed on the
Paydata Page
When Request is
Processed
Successfully:

Notes

1
Send in Temporary
Cost Number.

2

001000 (Any value
which is set up in the
Validation table
for Cost Number)

Data sent from the
following is displayed
under Temporary
Cost Number: 
/allocationTypeCode /
codeValue.

The values sent
in allocationTypeCod
e should be set up in
the Validation table
for Cost
Number before being
used. Otherwise, the
result is an error.

2
Send in Temporary
Department Number.

3

002000 (Any value
which is set up in the
Validation table
for Department)

Data sent from the
following is displayed
under Temporary
Department Number: 
/allocationTypeCode /
codeValue.

The values sent
in allocationTypeCod
e should be set up in
the Validation table
for Department befo
re used. Otherwise,
the result is an error.

3

Send
in Allocation for Cost
Number with
both Automatic and 
Manual set up
in Company Options.

1 "" and 1-99

Data sent
from /allocationTypeC
ode /codeValue is
displayed under ALA
Position.

When Automatic and
Manual is set up, it
takes values as "" and
1-99.

4

Send
in Allocation for Dep
artment
Number with
both Automatic and 
Manual set up
in Company Options.

       

5

Send
in Allocation for Cost
Number with
only Automatic set
up in Company
Options.

  "" and 1  
When Automatic is
set up, it takes values
as "" and 1.

6

Send
in Allocation for Dep
artment
Number with
only Automatic set
up in Company
Options.

       

7

Send
in Allocation for Cost
Number with
only Manual set up
in Company Options.

1 "" and 2-99

Data sent
from /allocationTypeC
ode /codeValue is
displayed under ALA
Position.

When Manual is set
up, it takes values
as "" and 2-99.

8

Send
in Allocation for Dep
artment
Number with
only Manual set up
in Company Options.

       


